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Chapter: 1 No. of Questions : 9

1) Which of the following is not a word processor?

a) Notepad b)Star Writer c¢)MS Word d) Word Star
2) The key used to delete the character to the left of the insertion point is
a) Delete b) Space Bar c) Backspace d) Enter

3) The shortcut key used to move to the beginning of a document is
a) shift + Home b) Home + Enter c)ctrl+B d) ctrl + Home
4) In Star Office, text document can be created using
a) StarOffice Calc  b) StarOffice Writer c) StarOffice Impress ' d) StarOffice Base
5) The selection shortcut used to select the entire document in StarOffice Writer is

a)ctrl+R b) ctrl + C c)ctrl+V d)ctri+ A
6) The keyboard shortcut to cut a selected text is

a)ctrl + X b) ctrl +V c)ctrl+B d) ctrl+C
7) In StarOffice Writer, the key pressed to enter a hard return is

a) Space bar b) Backspace c) Enter d) Esc
8) In StarOffice Writer, the flashing vertical bar is called as

a) end of document marker b) cursor

c) insertion point d) insertion bar

9) In StarOffice Writer, entering a new text or modifying the existing a text in a document is known

as
a) formatting b) hanging c) text editing d) inserting
10) Which command is selected to.cut the selected text in StarOffice Writer?
a) File>Cut b) Edit->Cut c) Format—>Cut d) Tools=>Cut
11) A word processing document may contain
a) text and tables - b) graphs and charts c) picture d) all of these
12) The thick horizontal line in the pagearea is called
a) end of paragraph marker b) end of page marker
c) end of document marker d) end of line marker
13) In StarOffice Writer, the menu used to switch between multiple documents is
a) File b) Window c) Edit d) View
14) The keyboard shortcut for the centre alignment of selected paragraph is
a) ctrl+ L b) ctrl + R c)ctrl+E d) ctrl + A
15) __ a document does not move the insertion point
a)Paging b)scrolling c)deleting c)wrapping
16) Which of the following keys is pressed to move the insertion point one word left in StarOffice
Writer?
a) ctrl + left arrow b) alt + left arrow c) shift + left arrow d) tab + left arrow

17) To move the insertion point to the beginning of the line press

a) End key b) Home key c) Up arrow key d) Down arrow key
18) Which consists of several applications?

a) StarOffice Base b) StarOffice Writer c) StarOffice Calc d) StarOffice
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19) Which key is used to delete the characters to the right of the insertion point?

a) Backspace b) Spacebar c) Delete d) Enter
20) Which key should be pressed to insert a blank line in a StarWriter document?
a) Home b) End c) Delete d) Enter
21) Which command is used to open an already existing document?
a) File>Open b) File>Save c) File>Close d) File> New
22) Which key is used to move down on screen in the document?
a) Page Up b) Page Down c) Home d) End
23) Which command is used to quit from StarOffice?
a) File>Quit b) File>Close c) File>Exit d) File=>Abort
24) Which shortcut key is used to copy the selected text?
a) ctrl + X b) ctrl +V c)ctrl+E d)ctrl+C
25) Which key is pressed to toggle between type over mode and the Insert mode?
a) Insert b) Alt c) Ctrl d) Shift
26) Which application is used to draw in Star Office?
a) StarOffice Writer b) StarOffice Base c) StarOffice Draw d) StarOffice Impress

27) The button used to skip the found text in StarOffice Writer is
a) Find All b) Replace All c) Replace d) Find
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Chapter: 2

1) The key board short cut for Bold is

a)Ctrl +U b) Alt + B c)Alt+C d) Ctrl +B
2) Which font looks professional?
a) Fajita b) Arial c) Windings d) Times New Roman
3) Bullets and Numbering option is available under
a) File b) Format c) Edit d) View
4) Which is a set of characters in a certain style?
a) Font b) Symbol c) Text d) Document
5) What can be used to call attention to key ideas in the document?
a) Editing b) Formatting c) Highlighting d) Indenting
6) In StarOffice Writer, under which menu all the formatting options are available?
a) File b) Edit c) View d) Format
7) Which keyboard shortcut is used to display Help in StarOffice Writer?
a)F1 b) F7 c) shift + F1 d) ctrl+ F1
8) The named set of defaults for formatting textis
a) Help agent b) Style c) Highlighting d) Indentation
9) Which of the following is the decorative font?
a) Times New Roman b) Arial Black c) Arial d) Fajita
10) In the absence of a colour printer, the document will.be printed as ___ on a black and white
printer
a)pattern b)gray c)shades of ray d)bright black
11) The size of the font is measured.in
a) Circles b) Rectangles c) Points d) Numbers
12) Bold, Italic, Underlined options are available under ___list box
a)Style b)Size c)Format d)Typeface
13) If the value of first line spin box in the paragraph dialog box is negative, it will create
a)indent b) Hanging Indent c) Left Indent d) First line indent
14) _ isnot a line space in StarOffice Writer
a)l.5 Lines b)Proportional c)Atleast d)Ratio
15) An.inch is equal to
a) 72 points b) 75 points c) 80 points d) 74 points
16) Which of the following is true, to change the fonts in StarOffice Writer?
a) Insert>Font b) Format—>Font c) View—>Font d) Format—>Character
17) Which option is to be selected from the color palette to remove the highlighting for the selected
text?
a) Character b) Font c) No Fill d) Format
18) A hard return is inserted every time when ___ is pressed
a)enter key b)space bar c) alt key d)ctrl key

19) Which is used to list the important points and message in StarOffice Writer?
a) Auto Correct b) Bullets and Numbering
c) Paragraph Alignment d) Editing
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20) The command sequence to create bulleted list

a)Format — Bullets and Numbering b)Tools — Bullets and Numbering
c)Edit — Bullets and Numbering d) File — Bullets and Numbering

21) Each time when increase indent icon is clicked, the paragraph isindented by
a) 1inch b) 2 inches c) % inch d) % inch

22) __ list will work well for points to present in sequence
a)Numbered b)Data c)Numbered d)Proportional

23) ___ areinserted as line breaks by Star Office Writer and adjusted when text is added or deleted
a)Soft return b)Hard return c)line space d)comma

24) _ will give Extended Help
a)Shift + F1 b) Ctrl + F1 c) Alt + F1 d) Tab + F1

25) This will appear when you perform complex task
a) Style List b)Extended Help c) Highlighting d)Help Agent
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Chapter: 3

1) The key pressed to select the spelling command is

a)F1 b) F7 c) F9 d) F5
2) Which button is clicked to include the word to the dictionary?
a) Include b) Replace c) Move d) Add
3) The only check box in the auto correct dialog box is
a) text only b) numbers c) match case d) whole words only
4) and ___ aretheicons are related to Spelling Check
a)Auto Spellcheck , Spellcheck b) Default Check, Spellcheck
c)Quick Spellcheck, Dialog Check d) Default Check, Quick Spellcheck
5) The button used to skip the spelling change only for the current word is
a) Change b) Ignore All c) Ignore Once d) Change All
6) The command to open a spell check dialog box is
a) Edit>Spelling> Check b) Tools—>Spelling=> Check
c) Edit>Check—>Spelling d) Tools=>Check—>Spelling
7) Which of the following keys is pressed to delete.a misspelled word and the word is retyped?
a) End b) Home c) shift+Delete d) Backspace
8) In StarOffice Writer, to create AutoCorrect entry, the commandusedis
a) Edit=>Auto Correct b) Format=>Auto Correct
c) Tools>Auto Correct d) Tools=>Spell Correct
9) To skip all occurrences of the misspelt word in spell check which button is clicked?
a) Change all b) Ignore All c) Notin dictionary d) Skip All
10) Which is very useful for correcting the spelling of the commonly misspelled words?
a) Auto spell checkicon b) Replace All
c) Change All d) Table Insert
11) __ click.on a misspelled word to get a pop up menu with more spelling option
a)Single b)Double c) Right d) Alt + Right

12) Which displays any alternate spelling in the spell check dialog box in Star Writer?

a) Choices b) Not in dictionary c) Dictionary d) Suggestions
13) Spelling mistakes are underlined in

a) Green b) Yellow c) Red d) Grey
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Chapter: 4

1) Which of the following keys is pressed to move backward through the cells of a Star Writer

Table?
a) ctrl + Tab b) Enter + Tab c) Esc + Tab d) Shift + Tab
2) To add a row after the last row of the table in Star Writer, the key pressedis
a) Shift b) Tab c) Alt d) Ctrl
3) The command to create a simple tableis
a) Insert>Table>Table b) Table=>Insert
c) Table=>Insert->Table d) Format—~>Insert->Table
4) Which of the following is a grid with a specified number of columns and rows in StarOffice
Writer?
a) Cell b) File c) Border d) Table
5) In StarOffice Writer, the command used to insert more than one row in a tableis __~
a) Insert>Table>Rows b) Table=>Insert->Rows
c) Insert>Rows d) Table >Rows
6) The command used to delete the selected table.in StarOffice Writeris
a) Table>Delete>Table b) Delete>Table
c) Format—>Table—>Delete d) None of these
7) In StarOffice Writer, which of the following commands is used to get a table format dialog box?
a) Table>Table Format b) Insert—>Table properties
c) Insert>Table d) Table>Table properties

8) By default, each cellinatable includesa.
a) border b) row c¢)-column d) row and border

9) To resize a column, place the cursor in the table cell, hold down __ and press left or right arrow
a)Ctrl b) Alt c) Space d) Tab

10) To resizesa column;, without changing the width of the table, place the cursor in the table cell,
hold down __ and press left or right arrow

a)Ctrl + Shift b) Alt + Ctrl c) Alt+ Space d) Ctrl + Tab
11) To resize a row, place the cursor in the table cell , hold down __ and press up or down arrow
a)Ctrl b) Alt c) Space d) Tab
12) Which‘command is used to delete the selected columns in Star Writer?
a) Tools—>Delete=>Columns b) Table> Delete-> Columns
c) Format—> Column—>Delete d) Format—>Delete>Columns

13) In a table, when the text is wrapped in a cell, it grows
a) wider b) wrap c) taller d) border
14) In a table in StarOffice Writer the intersection of a row and a columniscalleda
a) row b) cell c) width d) column
15) Which one of the following is to be selected to make all columns even?
a) space equally=>column b) width equally=>columns
c) column—>width equally d) column->space equally
16) In Star Writer the first Icon in the floating toolbar for table formatting functionis
a) Merge Cell b) Borders c) Insert Table d) Split Cell
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Chapter: 5

1) If the length of the document is more than the width, the orientation is called as __

a) Portrait b) Landscape c) Layout d) Margin
2) In StarOffice Writer, the page preview option is available under the menu
a) Format b) Edit c) File d) View
3) How many types of page orientations are there?
a)1 b) 2 c)3 d)4
4) In StarOffice Writer, to display the ruler on the screen select ruler under
a) File b) Edit c) Format d) View
5) __ dialog box is used to set the width of the paper
a)Page Style b)Paragraph c)Page Format d)Page View

6) The default width of a page in default orientation is

a) 8.5inch x 11 inch b) 11inch x 8.25inch  ¢) 11.inch:x 8.5 inch d) 8.5 inch x 1 inch
7) The default page orientation is

a) Book b) Landscape c) Handout d) Portrait
8) In atext document, the area at the top of therpageiscalledas

a) Footer b) Header c) Page number d) None of these
9) Margins can be changed using

a) Page Style dialog box  b) ruler c)both a and b d) table format dialog box
10) Which of the following dialog boxes can be used to set the margins in StarOffice Writer?

a) Format b) Table c) Page Style d) Paragraph
11) The width of a document will be more than the length called

a) Portrait b) Paper source c)-Paper format d) Landscape
12) In StarOffice Writer, the default top and bottom margins are

a) 1inch b) 1.25 inches c) 1.5 inches d) 0.5 inch
13) The default margins for top, bottom and left, right margins are

a)1.25”, 1” b)1”, 1.25” c)1”, 1” d) 1.25”, 1.25”
14) n StarOffice Writer, the command to open the Page Style dialog box is

a) File>Page b) Edit> page c) Format->Page d) View—>page

15) How many methods are used to change the page margins?
a) three b) six c) four d) two
16) __ isthe area at the top of page
a)footer b)topper c)header d)titler
17) In StarOffcie Writer, the command to insert numbers in the footer area of the documentis __
a) Insert>Page number b) Insert—>Fields—>Page Numbers
c) Insert=>Field> Number d) Format—>Page Number
18) Which are some references and remarks added at every page of the document of the top and
bottom margins respectively?
a) header and footer b) top and bottom
c) title and reference d) heading and page number
19) In page style dialog box, which tab is used to select the page orientation?
a) Header b) Orientation c) Page d) Footer
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Chapter: 6 No. of Questions : 7

1) The first electronic spreadsheet is
a) Star Calc b) Visi Calc c) Excel d) Lotus
2) ‘Improve’ spreadsheet was developed by

a) Lotus corporation  b) Microsoft c) apple d) Borland
3) How many rows and columns are there in VisiCalc?

a) 524, 36 b) 254, 36 c) 254, 63 d) 63, 254
4) ‘VisiCalc’ was invented by

a) Dan Bricklin b) Bob Frankston c) Bill Gates d)Both a and b
5) __ isthe last column in VisiCalc

a)lv b)BK c)KB dvi
6) The key combination used to open print dialog box in Star Office Calc is

a) ctrl + shift +P  b)ctrl+P c)alt+P d) shift + P
7) Which key is pressed while editing the contents in a cell?

a) F1 b) F2 c) F5 d) F7
8) A formula in spread sheet always begins with

a) + b) - c)A d) =
9) Which of the following operators combines two texts?

a) + b) |1 )& d) S
10) Which of the following is the reference operator?

a) % b) <> c)! d) &
11) The operator <> is usedto check

a) equal b) greater than c)-less than d) inequality
12) Which of the following operators combine cell areas in StarOffice Calc ?

a) Reference b) Comparative c) Text d) Arithmetic

13) Which of‘the following icons is used to generate a scrolling screen within worksheet?
a) Insert'Plug-in b) Insert Floating Frame c) Insert OLE Object d) Insert Chart
14) The active cell in a speared sheet is identified by
a) Insertion point  b) Keyboard pointer c) Mouse pointer d) cell pointer
15). The cells A4, A5, A6, B4, B5 & B6 are referred in a worksheet as
a) A4 :B6 b) Al: B6 c) A1:A6; B1:B6 d) A4:A6; B4:B6
16) Which bars have shortcut icon for frequently done tasks in the spreadsheet?
a) menu bar b) formula bar c¢) Object & Function bar d) Main tool bar
17) Which of the following formula calculates the sum of the numbers in the cell Al of sheetl and
A2 of Sheet2?
a) =sum(sheet1.Al + sheet2.A2) b) = sum(sheetl.Al; sheet2.A2)
c) =sum(sheetl:Al; sheet2:A2) d) =sum(sheet1.Al:sheet2.A2)
18) To do the calculations for different worksheet in a particular sheet, we use
a) 2D formula b) function c) 3D formula d) selection
19) Which of the following data can be typed into a spread sheet cell?
a) numbers b) text c) formulae d) all of these
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20) Which facility of StarOffice Calc helps to format the worksheet with different predefined styles
and colours?
a) Auto Format b) Applet c) Chart d) Multiple Sheets

21) In Star Office Calc, when column width is not enough for the content, it will be indicated with a

small

a)Yellow Triangle  b)Blue Triangle c) Green Triangle d)Red Triangle
22) The bar used to display the current cell and its content is

a) menu bar b) object bar c) formula bar d) function bar
23) A continuous group of cells in a worksheet is called as

a) column b) row c) data sheet d) range
24) Graphic representations of numbers are known as

a) Graphs b) Charts c) Bar diagrams d) cells
25) The format for entering date in StarOffice Calc is

a) YY/MM/DD b) YY/DD/MM c) DD/MM/YY d) MM/DD/YY
26) The time format will be entered in ___ format

a)HH:MM:SS b) HH-MM-SS c)HH:MM d)HH/MM/SS
27) The cell referencing that does not get changed when copiedis

a) Absolute Cell Addressing b) Relative Cell Referencing

c) Reference d) Comparative
28)  dialog box can be used to delete entire row

a)Delete Content b)Delete Any c)Erase Content d) Delete Cells
29) Which one of the following notations is used to create absolute cell addressing?

a)! b) $ c) & d):
30) Which icon is used to insert object from otherapplication into a worksheet?

a) Insert Applet Icon b) Insert Floating Frame

c) Insert Formula d) Insert OLE object
31) Which icon is used to import Applets written in Java Programming into a worksheet?

a) Insert Applet Icon b) Insert Floating Frame

c) Insert Formula d) Insert OLE object
32) Which of the following commands is used to generate a series in Star Offic Calc?

a) Page style b) Print range c) Fill d) Page format
33) How many cells are available in the worksheet range C1 : E2 ?

a)6 b) 8 c) 10 d)4
34) Predefined formulae that are available in StarOffice Calcare ___

a) Relative Cell Referencing b) Cell Address

c) Absolute Cell Referencing d) Functions
35) Which option on the file menu can be used to preview a worksheet before printing?

a) Page setup b) Print c) Page View d) Page setup default
36) In StarOffice Calc, which command is used to change the width of the column in a word sheet?

a) Insert>Column—->Width b) Insert>Width->Column

c) Format—=>Column—>Insert d) Format—> Column->Width

37) Which of the following reference operators is named as ‘Intersection’?
a)! b) : c) & d) =




HOLYCROSS Star Office - Objective Type Answers

38) The function used to find the square root of a given number is

a) sqgr() b) sqrt() c) sqt() d) square root()
39) The cell B4 becomes absolute when you enter
a) BS45 b) SB4S c) $BS4 d) BSS4
40) The spreadsheet package ‘StarOffice Calc’ was developed by
a) Microsoft Corporation b) Borland International
c) Lotus Corporation d) Sun Microsystems
41) Which of the following is an exponentiation operator in StarOffice Calc?
a)% b) A c) * d)./
42) Which of the following refers to the files that you create with spreadsheet software?
a) worksheet b) text document c) data base d) data sheet
43) Which command is used to print the worksheet with grid lines ?
a) Format—>sheet b) Format->Page c) Format—>Grid d) File=>print=>Grid
44) s available at the bottom right corner of the cell pointer
a)copy b)fill handle c) duplicator d)eraser
45) Which operator is used to refer range in StarOffice Calc?
a)! b) & c): d)~
46) Which is the default type of cell address used by StarOffice Calc?
a) Relative cell addressing b) Absolute cell addressing
c) Primary cell addressing d) Relational.cell addressing
47) If the data entered is a word, spread sheet recognizes it as a
a)Number b)Date c)time d)Label
48) Which is the most commonly used function in StarOffice Calc?
a) SQRT() b) SUM() c) AVERAGE() d) POW()
49) Which command is used to generate a series?
a) File>Fill>Series b) View—>Fill>Series
c) Tools=>Fill>Series d) Edit>Fill> Series
50) Which is a spread sheet program?
a) StarOffice Impress b) Flash c) Improve d) Lotus Amipro
51) Which is used to calculate and analyze sets of numbers?
a) Charts b) Presentation c) Function d) Impress
52) . describes the format of specifying a formula
a)Formula b)Syntax c)Layout d)None of these

53) In Star Calc, amongst arithmetic operators which one of the following is executed first in the
rules of precedence?

a) Negative b) Exponentiation
c) Multiplication & Division d) Addition & Subtraction
54)  symbolis used for exponentiation
a b)@ c)n d)%
55) Find the correct order of precedence of arithmetic operators
ap -/ %A b) * / "+ - Q) */+- d)n*/+-

56) In Star Calc, to begin with a worksheet, the cell pointer is always in
a) BA b) Al c) AB d) 1A
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57) A grid of cells with a programmable calculator attached to each cell is _
a) computer b) Visicalc c) datasheet d) spreadsheet
58) Which operator is not an arithmetic operator in Star Calc?
a) % b) A c)<> d) *
59) Which is used to make data easier to understand?
a) chart b) formula c) function d) object
60) Which electronic spreadsheet was invented for Apple Il computers?
a)Lotus 1-2-3 b) Visicalc c) Excel d) Improve
61) The spread sheet developed by Microsoft is

a) Quattro Pro b) VisiCalc c) Improve d) Excel
62) In spreadsheet rows are represented as

a) Alphabet b) number c) symbol d) functions
63) __ can be used to bring Delete Contents Dialog box

a)Tools — Delete Contents b)Edit —Delete Contents

c)Format — Delete Contents d)File — Delete Contents
64) The spread sheet “Improve” is from

a)Microsoft Corporation b)Sun Microsystem

c)Borland International d)Lotus Corporation

65) Which button is held down and then pressed the left or right arrow to resize a column width?
a) shift b) ctrl c) alt d) F1
66) Which of the command is used to print the selected range in Star Calc?

a) Format—->Print Range > Remove b) Format—>Print Range—> Delete

c) Edit>Print Range d) Format—> Print Range—> Edit
67) ___ option allows you to print only the selected area in a work sheet

a)Range b)selection c)cover d)set print
68) In StarCalc, which feature automatically generates a data series based on a defined pattern?

a) Auto Fill b) Function c) Auto format d) Series type
69) To draw ellipse, ___is used

a)Show Draw Functions icon b)Draw Ellipse Icon

c)Draw Ellipse Function d)Show Picture icon
70).Quattro Pro spreadsheetwas developed by

a) Microsoft Corporation b) Borland International

c) Lotus Corporation d) Sun Micro Systems
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Chapter: 7 No. of Questions : 9

1) The field type that is not allowed by StarOffice Base is

a) text b) binary c) image d) project
2) The term data is derived from the word

a) Datum b) Datem c) Datas d) Datus
3) A column in a Star Office Base table represents a

a) Structure b) File c) Record d) Field
4) The key that uniquely identifies a record in a data base is

a) Secondary key  b) Unique key c) Primary key d) Record key
5) The process used to select the desired specific data from a database is called

a) merging b) searching c) editing d) sorting
6) Which is a type of query?

a) table b) forms c) filter d) report
7) How many steps are there in the report wizard window?

a)7 b) 8 c)9 d)6
8) What is a way of limiting the information thatappears on screen?

a) filtering b) merging c) report d) searching
9) The set of processed data is called

a) data b) datum ¢) information d) database
10) Each row in a database table represents

a) File b) Record c) Field d) Table
11) A database that consists of a single data table is

a) Relational b) Network c)-Hierarchical d) Flat-file
12) The computers that primarily use the hierarchical data base are_____

a) super b) mainframe c) personal d) mini
13) DBMS is an acronym for

a) Database Maintaining System b) Database Management System

c) Database Manipulating System d) Database Merging System
14) The accurate length of decimal digits in a double precision number is

a) 14 b) 13 c)8 d)7
15) Which'of the following are user constructed statements in StarOffice Base?

a) Filters b) Forms c) Queries d) Reports

16) Filter used with a condition is called
a) Auto filter b) Unconditional Filter  c) Default Filter d) Conditioned Filter
17) In StarOffice Base, which is a printed information that is assembled by gathering data based on
user supplied criteria?

a) Filter b) Query c) Form d) Report
18) SQL stands for

a) Sorted Query Language b) Structured Query Language

c) Structured Question Language d) Sorted Question Language

19) To insert spreadsheet Calc range of cells in StarOffice Writer, select
a) Edit>Paste b) Edit->Paste Special c) Tools=>Paste special d) Format—=>paste
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20) Which of the following is not a step in data processing?

a) Collection b) Verification c) Computation d) Validation
21) The number of field types used in StarOffice Baseis

a) 20 b) 30 c) 12 d) 13
22) What is the name of the process for joining data from two or more tables?

a) joining b) editing c) merging d) adding
23) Which of the following options is used to remove the filter?

a) Remove filter b) Delete filter c) Remove filter / sort d) Delete filter / sort
24) A screen that display the fields of a record in a well spaced out manner.is

a) window b) report c) table d) form
25) In database, which option is used to define the maximum size of a field?

a) default value b) length c) type d) value
26) The key combination used to save the database tableis

a)ctrl+C bctrl+V c) ctrl +S d) ctrl + A
27) The process of arranging the data in some order in a table is called

a) sorting b) filtering c) searching d) merging
28) Which of the following is the special view of the datain a table?
a) sorting b) filtering c) Queries d) editing
29) To insert a text outline into presentation, choose
a) File> Insert=>Presentation b) File>Send—> Presentation
c) File=>Insert=>Outline to Presentation d) File->Send=>Outline to Presentation
30) Spreadsheet is an example of which of the following databases?
a) flat file b) network c) relational d) hierarchical
31) Which of the following are called the common fields in a relational database?
a) files b) keys c) records d) table
32) Which is used to assemble information from data?
a) Datum b) Information c) DBMS d) Sorting
33) To create a new table in StarOffice Base, the command used is
a) Table=>Insert b) Table>Table Design
c) Format—>Table Design d) Insert->Table Design
34).To sort the records.in the'ascending order, select the field and clickon
a) Sort Ascending icon b) Ascending Icon
c) Sort.icon d) Sort/Filter icon
35) To copy the selected cell range in text document select which option in the paste special dialog
box?
a) paste b) DDE Link c) OLE link d) link

36) A set of processed datais called
a) datum b) procedure c) information d) database
37) A repository of collections of related data or facts is called a / an
a) table b) file c) information d) database
38) Which database structure is characterized by parent-child relationships among record types?
a) Flat File database b) Relational database
c) Hierarchical database d) Network database
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39) A screen that displays data for a single record iscalleda

a) table b) form c) query d) report
40) How many general categories are there in DBMS?

a)4d b) 2 c)6 d)3
41) Which is used to arrange records in alphabetical or numerical order?

a) searching b) sorting c) merging d) filtering
42) How many different databases are there in StarOffice Base?

a)2 b) 4 c)5 d)3
43) Which command is used to open StarOffice Base?

a) File->New—>Database b) New—>File>Star Base

c) View—>Data base d) File>StarOffice Base
44) Which language is used to query the database?

a) C++ b) saL ) HTML d) DBMS
45) Which amongst the following consists of usable sets of data.?

a) form b) field c) information d) record
46) In StarBase, which one of the following is not a process in editing the database?

a) Adding new record b) Changing format of the database

¢) Calculating result d) Deleting existing data
47) In StarBase, a small triangle on the left most column of the tableiscalled

a) insertion point  b) field pointer c) table pointer d) record pointer
48) The command used to save the database tableis

a) File>Save b) File>Tools—>Save c) Edit>Save d) Edit>Fill>Save
49) In computers, the value assigned to a variable is called

a) key b) information c) report d) data
50) A collection of related table is what in Staroffice Base?

a) a form b) a report c) a database d) a record
51) The two types of filters namely

a) auto, static b) auto, standard c) default, static d) auto, query
52) Standard Filter is also called as

a)Normal Filter b)Quick Filter c)Default Filter d)Void Filter
53) The entire collection of related data items in one table is

a) file b) record c) information d) field
54) To insert another form within the form, which checkbox is to be selected?

a) insert form b) sub form c) form insert d) add sub form
55) How many general categories of the data management tasks are there in DBMS?

a) two b) three c) four d) five

56) The command used to transfer each heading together with its accompanying paragraphs in the
text document into a presentation is
a) File>Send-> Auto abstract to presentation
b) File>Copy—>Auto abstract to presentation
c) File> Edit->Auto abstract to presentation
d) Edit>Send—> Auto abstract to presentation
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1) The shock wave format is used to store multimedia components created using
a) media player b) netscape navigator c) internet explorer d) Flash
2) The application that allows to send and receive messages over cellphone is _

a) Microwave Media Service b) Multimedia Media Service
c) Multimedia Messaging Service d) Microwave Messaging Service
3) JPEG may be expanded as
a) Joint Photographic Experts Group b) Joint Physical Exports Group
c) Joint Physical Experts Group d) Joint Photographic Exports Group
4) Which of the following is the commercial multimedia content development software?
a) Flash b) Dream Weaver c) Maya d) All of these
5) AIFF format was developed by
a) Real Networks  b) Dream Weaver c) Apple d) Microsoft
6) The technique that provides an environment experienced by users as similar to reality is
a) Virtual Reality  b) Vector Graphics c) Animations d) Modeling
7) Name of the technique of distorting a single.image to represent something elseis ___
a) Modeling b) Rendering c) Morphing d) Warping
8) Files in the Windows Media format have the extension
a) .wmv b) .mov c) .swf d) .wmf
9) Which of the following tags is.not used to launch helper applications?
a) <embed> b) <name> c) <applet> d) <object>

10) Which of the followingis.a computer based presentation technique that incorporates text,
sound, animations and video elements?

a) Animation b) Modeling c) Compression d) Multimedia
11) GIF stands for
a) Graphic Interchange Format b) Graphic Information Format
c) Graphical Interface Format d) Graphic Interconnection File
12) The expansion for MIDl'is
a) Musical Instrument Data Interface b) Musical Instructions Digital Interface
c) Musical Instrument Digital Interface d) Musical Information Data Interface

13) The technique of identifying recurring set of information and replacing them by a single piece of
information is called as

a) Virtual Reality ~ b) Vector Graphics c) Synthesize d) Compression
14) The special hardware used to improve the efficiency of the display images is

a) Vector Graphics Card b) Vector Card

c¢) Vector Image d) Vector Graphics Chord

15) Which of the following formats creates a perfect reproduction of images?
a) MIDI b) GIF c) JPEG d) BMP
16) Files in the Quick Time format have the extension
a) .wmv b) .mov c) .wav d) .swf
17) The shockwave format was developed by
a) Microsoft b) Apple c) IBM d) Macromedia




HOLYCROSS Star Office - Objective Type Answers

18) The conversion of analog sound waves to a digital format is called

a) Frequency b) Pitch c) Sampling d) Amplitude
19) Which is not in the step process of creating a 3D animation?

a) Modeling b) Moving c) Animating d) Rendering
20) GIF is limited to the palette of

a) 4 bits b) 6 bits c) 8 bits d) 10 bits
21) The technique of blending two or more images to form a new image is _

a) Morphing b) Warping c) Sampling d) Rendering

22) The compression that retains the exact image throughout the compression is called
a) Lossy b) Lossless c) Jerky d) Murky

23) Multimedia applications that allow users to actively participate instead of just sitting by as
passive recipients of information are called as
a) Computer Based Tutorial b) Web Based Tutorial
c) Multimedia System d) Interactive Multimedia

24) The format that was developed by Macromedia and is used to store Multimedia components
creating using Flashis

a) AVI format b) Shock Wave format_ ¢) MIDI Format d) Wave format
25) In which year AVI format sound files are developed?

a) 1995 b) 1992 c) 1985 d) 1991
26) MPEG stands for

a) Moving Pictures Experts Group b) Model Pictures Expression Group

¢) Moving Pictures Expression Group d) Morphing Pictures Experts Group

27) In which year was real audio format developed?

a) 1982 b) 1995 c) 1994 d) 1981
28) Which tag is used to add in-line sound to.a web page?

a) <inline> b) <sound> c) <bgsound> d) <helper>
29) The most common version of e-learning packages is

a) CBT / WBT b) CBE / WBE c) CB/WB d)CT/WT
30) The AVIformat was developed by

a) Apple b) IBM c) Macromedia d) Microsoft

31) Files in the Quick Time format have the extension as
a) .wmv b) .mov c) .wav d) .swf

32) Reducing the colour depth to less than how many colours result the image to look murky?
a) 254 b) 263 c) 255 d) 256

33) The Real Audio format has the extension

a).rmor .rf b) .ram or .rF c) .rmor .ram d) .r, or .rads
34) ‘Snd’ format was developed by

a) Apple b) IBM c) MPEG d) Microsoft
35) Frequency is also called as

a) Pitch b) Crest c) Sampling d) Sound

36) How many steps are there to create a 3D animation ?
a) two b) three c) five d) four
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37) WBT stands for
a) Web Based Tutorials b) World Based Training
c) Web Based Training d) Window Based Training

38) Helper application is also called as

a) multimedia b) video c) plug-in d) audio
39) Which file format supports full colour and produces relatively small size files?
a) GIF b) NxView c) BMP d) JPEG
40) Reducing the frame count to less than how many frames per second causes the video to look
jerky?
a)7 b) 15 c) 28 d) 30
41) Which graphics help in rendering the image effectively on the screen?
a) Scalar Graphics b) Dynamic Graphics c) Vector Graphics d) Linear Graphics
42) Which is not well fitted for photographic works?

a) GIF b) JPG c) NxView d) BMP
43) In multimedia, the pattern of the sound that you hear is

a) digital wave b) analog wave c) hybrid wave d) frequency
44) Files in the AIFF format have the extension

a) .avi b) .aud c) .wav d) .aif
45) Which ending program is used to add-echo, fade out, fade in effects?

a) digital format b) sound program c) sound forge d) digital sampling
46) CBT stands for

a) Computer Based Tutorials b) Corporate Based Training

c) Computer Based Traihing d) Command Based Training
47) MIDI format was developedin

a) 1990 b) 1085 c) 1995 d) 1982
48) Which of the following animation is referred to as slide or path animation?

a) Modeling b) Object Based c) Cel Based d) Rendering
49) Which of the following is not a multimedia element?

a) Text b) Video c) Database d) Sound
50) Which option is used to apply the colours to the HTML pages?

a) Use Presentation b) Use Chart Colours

c) Use Browser Colours d) Use graph Colours

51) How many types of compression are there in Image files?
a) two b) three c) four d) six
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1) In presentation the view that allows us to view miniature images of all the slides is

a) slide sorter b) master page c) notes view d) layout
2) The shortcut key for opening style listis

a)F8 b) F7 c) F5 d) F11
3) To change the background colour of the current slide, click on

a) Format->Page—>Background b) Tools>Page—>Background

c) Edit>Page—>Background d) View—>Page—>Background

4) The number of options displayed in the first page of the presentation wizardis .
a)2 b) 4 c)3 d) 5

5) Which of the following options display ‘Created with StarOffice” message during the pause
between each presentation?

a) Automatic b) Effect c) Show Logo d) Default
6) The view used to reorder slides is
a) normal b) outline c) notes d) handouts
7) To open media player window, choose
a) Tools~>Media Player b) Edit>Media Player
c) Insert->Media Player d) View—>Media Player
8) Which is not a Background fill option?
a) Color b) Gradient c) Picture d) Hatching

9) In StarOffice Impress, the window allows to quickly jump from one slide to other slide or move
between open filesis

a) Desk Top b) Preview c) Navigator d) Moving Slide
10) The keyboard shortcut used to create a new presentation using template is
a)ctrl + N b)alt +N c)ctrl+ F+N d) shift + ctrl + N

11) Which one of the following displays various transition effects that can be attached to a slide?
a) Custom animation b) Slide Transition c) Animation effects  d) Slide sorter

12) Which button is pressed to start the slide show in StarOffice Impress?
a)F1 b) F3 c)F5 d) F7

13) To rename a slide, choose slide 2>

a) Rename Slide ~ b) New Slide c) Rename d) Slide Rename
14) Presentations can be created using

a) StarOffice Writer b) StarOffice Calc c) StarOffice Base d) StarOffice Impress
15) Which view is allowed to create and edit slides?

a) Outline view b) Normal View c) Notes View d) Master Page
16) To produce HTML presentation, choose

a) File2>HTML b) File>Export c) Edit>Export d) Edit> HTML
17) Which key combination is used to print slides in StarOffice?

a)alt+P b) shift + P c)ctrl + P d) shift + ctrl + P
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18) In StarOffice Impress, the page used to specify basic background information that needs to be
included in all the slides is

a) Slide Transition b) Custom Animation c) Layout d) Master Page
19) Which command is used to insert a picture in a slide?

a) Insert—> Picture—> From File b) Format—>Picture

c) View—=>Picture=>Insert d)Insert—> Picture

20) Which of the following is used to import objects from other application into a presentation?
a) Insert Object b) Insert OLE Object c) Insert Plug-in d) Insert Application
21) Which command is used to open Navigator?
a) File->Navigator b) Tools—> Navigator c) Edit> Navigator d) Insert->Navigator
22) The command that is used to create a new Impress presentation from within any StarOffice
application is

a) File>Presentation b) File>New—>StarOffice Impress
c) File->New—>Presentation d) File>New~> StarOffice Presentation
23) To insert a slide, choose
a) Slide=>Insert b) Insert->Slide c) Format—>Slide Insert  d) Presentation—=>Slides
24) Which is used for performing calculations in-presentation?
a) Insert OLE Object b) Insert Object c) Insert Applet d) Insert Formula
25) Which key is used to stop the presentation before the end?
a) Enter b) Backspace c) Escape d) F5
26) The command used to hide a.selected slide is
a) Slide Show—> Hide / Show Slide b) Slide Show—> Show / Hide Slide
c) Slide>Hide Slide d) Slide>Hide
27) Which determines the text formatting style for title, outline and background design for single or
all slides?
a) Master Page b) Master Text c) Master Slide d) Master Format
28) Which key is used to select multiple slides?
a) alt b) ctrl c) shift d) tab

29) Which option allows you to manually control the transition of slides using options such as
mouse click?
a) Show Logo b) Effect c) Automatic d) Default

30) The command to create a new presentation using template is
a) File>New—>Templates and Documents  b) Format->New—->Templates

c) File>Template d) Format>Templates and Documents

31) In Star Impress, which Spin box allows you to specify the duration for the slides in presentation?
a) Duration of pause b) Duration of page
c) Duration of date d) Duration of time

32) In presentation window how many tabs are there in the centre pane?
a) Four b) Six c) Three d) Five
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